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Introduction  

Purpose 
This document guides you through the installation process for the DataSplice Mobile 
Integration Suite.  The software suite consists of the DataSplice Server, the 
Administration Client, and the Remote Client.  Each component can be installed on a PC 
during the installation process.  In addition, this guide explains the process of installing 
the DataSplice Remote Client application on a mobile device. 

After the software has been installed, you will need to configure certain aspects of the 
software to fit your particular needs.  This guide also details those initial configuration 
steps. 

For additional information about the behavior of the different components of the 
DataSplice Mobile Integration Suite, please see the user manual for the corresponding 
component. 

For additional documentation and support resources, please visit 
http://support.datasplice.com. 

Version Information 
 
The information in this guide pertains to DataSplice version 2.3.10.0. 
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DataSplice Mobile Integration Suite 
Installation 
To use the DataSplice Mobile Integration Suite, you must first follow the required 
installation and configuration steps.  The sections listed below detail the installation 
process: 

• System Requirements 
• Installing the DataSplice Mobile Integration Suite 
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System Requirements 
The following information details the system requirements for running the various 
components of the DataSplice Mobile Integration Suite. 
 

Supported Operating Systems 
The DataSplice Mobile Integration Suite supports the following operating systems: 
 

• Microsoft Windows NT 4 (Workstation or Server) with service pack 6a 
• Microsoft Windows 2000 (Professional, Server, or Advanced Server) with the 

latest Windows service pack and critical updates available from the Microsoft 
web site 

• Microsoft Windows XP (Home or Professional) 
• Microsoft Windows Server 2003 family 
• Microsoft Terminal Server – DataSplice can be installed on Microsoft Terminal 

Server, but it may require significant effort to properly install the Microsoft XML 
parser 

 

Hardware Requirements 
Although the hardware required to run the DataSplice Mobile Integration Suite 
effectively is highly dependent on the number of client connections it needs to support, 
the following specifications are applicable to most implementations: 
 

• 500 MHz processor (1 GHz recommended) 
• 256 MB RAM (512 MB recommended) 
• 200 MB of available hard disk storage (500 MB recommended) 

 

Additional Required Components 
The following additional software components are also required for correct operation of 
the DataSplice Mobile Integration Suite: 
 

• Microsoft .NET Framework version 1.1 or newer 
• Microsoft Data Access Components (MDAC) version 2.6 or newer 
• Microsoft XML Core Services (MSXML) version 4.0 or newer 
• Microsoft Internet Explorer version 5.01 or newer 
• Microsoft ActiveSync version 3.6 or newer if manually installing the DataSplice 

Remote Client on mobile devices 
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Mobile Device Requirements 
To effectively run the DataSplice Remote Client application on a mobile device, the 
following requirements must be met. 

Supported Operating Systems 
The mobile device must be running one of the following operating systems for the 
DataSplice Remote Client to be installed correctly: 
 

• Pocket PC 
• Pocket PC 2000 
• Pocket PC 2002 
• Pocket PC 2003 (a.k.a. Windows Mobile) 
• Windows CE 2.11 or newer 
• Windows CE .NET 

 

Hardware Considerations 
The hardware requirements of the mobile device can vary considerably, depending on 
whether the DataSplice Remote Client will be used in online or offline mode.  In 
particular, storage space becomes more of an issue when the DataSplice Remote Client is 
being used in offline mode, as session data is being cached onto the device, rather than 
being stored on the DataSplice Server as it would be in online mode.  The use of non-
volatile storage media, such as an SD card, is recommended so data can persist if the 
mobile device is reset.  The following specifications can be used as a good general 
guideline: 
 

• 300 MHz ARM processor 
• 32 MB ROM 
• 64 MB RAM 
• 32 MB capacity storage card if non-volatile storage is desired (64 MB 

recommended) 
 

Networking 
The DataSplice Mobile Integration Suite can be used in wireless networks or in regular 
Ethernet-based networks.  In addition, the DataSplice Server can be accessed directly 
through an ActiveSync connection.  The following network capabilities must be enabled 
and accessible for the DataSplice Mobile Integration Suite to function correctly: 
 

• Port 4100 (or other port if other than default) 
• TCP/IP 
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Installing the DataSplice Mobile Integration Suite 
The DataSplice setup wizard guides you through the installation of each component of 
the DataSplice Mobile Integration Suite. 
 

Running the Setup Wizard 
Locate and run the DataSplice-2.3.10.0.msi installation file.  The basic steps are 
described in the following sections. 
 
At the Welcome dialog screen, click the Next button to begin the installation process.  Be 
sure to shut down any currently running programs before continuing with the installation.  
At any time during this process, click the Cancel button if you would like to abort the 
installation. 
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Selecting the Components to Install 
After choosing the destination directory, you will be prompted to select the DataSplice 
components you want installed.  The following dialog box shows the components that are 
available for installation: 
 

 
 
When the DataSplice Server component is selected, the Administration Client is 
automatically selected as well.  After selecting the desired components, click the Next 
button at the bottom of the window. 
 
Selecting the Windows CE Clients component installs the necessary files to allow you to 
manually install the DataSplice Remote Client onto mobile devices. 
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Choosing the Destination Directory 
Next, you will choose the destination directory for your installation.  The default 
destination folder is C:\Program Files\DataSplice.  You may accept this as the 
installation directory or choose a different location by clicking the Browse button.  When 
you are satisfied with the destination location, click the Next button to continue. 
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Confirming the Installation 
After selecting the components to be installed, the DataSplice setup wizard will attempt 
to install the selected components based upon the options specified in the previous 
sections.  Click the Next button to begin the installation of the desired components. 
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As the specified components are being installed, a progress bar will keep you updated on 
the status of the installation. 
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Completing the Installation 
You will be notified when the installation has been completed.  After successful 
completion of this step, click the Close button.  Setup is complete and control will pass 
back to the Windows desktop. 
 

 
 

Start Menu Group 
DataSplice icons will be placed in the DataSplice program group on the Start menu, 
unless an alternative location was specified. 
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DataSplice Remote Client Installation on 
Mobile Devices 
In addition to being installed on a PC, the DataSplice Remote Client application can be 
easily installed on mobile devices.  Using the Remote Client on mobile devices allows 
you to realize the true potential of the DataSplice software in a mobile environment. 
 
There are two methods to install the DataSplice Remote Client application on a mobile 
device: 
 

• Installing the DataSplice Remote Client Using Windmill 
• Installing the DataSplice Remote Client Manually 

 
A utility program can also be used on the mobile device to streamline certain actions in 
the DataSplice Remote Client.  The utility is explained on this page: 
 

• Configuring the Button Helper Utility 
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Installing the DataSplice Remote Client Using Windmill 
The first method of installing the DataSplice Remote Client application on a mobile 
device is to use the Windmill provisioning software.  Using Windmill is the preferred 
method of the two installation options, as it offers a more efficient and user-friendly 
installation process.  For Windmill installation and usage instructions, please refer to the 
Windmill Guide on http://support.datasplice.com.  
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Installing the DataSplice Remote Client Manually 
Alternatively, you may choose to manually install the DataSplice Remote Client onto a 
mobile device.  This is accomplished by using ActiveSync to transfer the necessary files 
from a desktop PC to the mobile device. 
 
If you are having trouble with ActiveSync or would like more information, please see our 
ActiveSync Frequently Asked Questions page at 
http://support.datasplice.com/FAQs/ActiveSyncTroubleshooting. 
 

Pre-Installation Considerations 
 

• Ensure that ActiveSync is installed on the desktop computer you will be using.  If 
you do not already have it on your desktop PC, you can download the latest 
version of ActiveSync at 
http://www.microsoft.com/windowsmobile/downloads/activesync38.mspx. 

• Ensure that the mobile device can communicate by either a cable (serial or USB), 
Ethernet connection, wireless card (802.11b), or infrared port with the desktop 
computer. 

• Ensure that the Network TCP/IP configuration and IP addressing is configured. 
• Ensure that DataSplice is not already running on the mobile device. 

 

Installation Steps 
 

• Start ActiveSync.  If it is the first time you have used ActiveSync with this mobile 
device, you may need to use the Get Connected wizard to connect.  The wizard 
will automatically create the proper connection.  If you are prompted to choose a 
type of partnership, you can select a Guest partnership, as this type of partnership 
will be sufficient for the installation process.  Again, see our ActiveSync 
Frequently Asked Question page at 
http://support.datasplice.com/FAQs/ActiveSyncTroubleshooting for more 
information. 

• The Connection screen will appear when a connection is established: 
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• Click the Explore Device button  or click File > Explore from the menu to 
open a file explorer window for the mobile device.  It will generally take a few 
seconds for device’s contents to be displayed. 

• If your device has an SD card or other non-volatile storage media, you should 
install DataSplice to that storage card.  Depending on the type of device and the 
type of storage card, this may be in a different folder location.  For example, a 
typical SD card’s contents are often located in the My Pocket PC\SDMMC Disk 
folder.  If you do not have a non-volatile storage card, browse to the My Pocket 
PC\Program Files folder.  Keep in mind, however, that if you do not install the 
files to non-volatile storage, they will be lost if the mobile device loses battery 
power or is cold rebooted (reset). 

• Right click on an empty area of the window and choose New Folder.  Name it 
DataSplice. 

• Open Windows Explorer on your desktop PC.  Browse to the directory where 
DataSplice was installed on the desktop PC.  By default, this is C:\Program 
Files\DataSplice.  In this directory, browse to the WindowsCE folder.  Now 
browse to the folder that corresponds to the chipset of your mobile device, such as 
ARM, MIPS, SH3, or SH4.  Lastly, depending on whether it is running on a Pocket 
PC (PPC) or a Handheld PC (HPC) platform, browse to the corresponding folder. 

 
Example: 
 
If you installed DataSplice in the default location on the PC, and your mobile 
device is an Intermec 750, which uses an ARM chipset on a Pocket PC platform, 
you would browse to C:\Program Files\DataSplice\WindowsCE\ARM\PPC. 

 
• Select all of the files from the appropriate directory on the desktop PC.  Right 

click the selection and choose Copy. 
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• Go to the explorer window of the mobile device.  You should still be in the 
DataSplice folder that you recently created.  Right click in the window and 
choose Paste. 

• You may be warned that some of the files will be converted when they are moved 
onto the mobile device.  Click OK to continue.  You should see a progress screen 
as the files are transferring over to the mobile device: 

 

 
 

• When the files have successfully transferred to the mobile device, you should see 
the files listed in the device’s DataSplice folder.  Right click on the 
DataSplice.exe file and choose Copy. 

• Browse to the My Pocket PC\Windows\Start Menu\Programs folder in the mobile 
device’s explorer window. 

• Right click on a blank area of this folder and select Paste Shortcut.  A shortcut 
file, named Shortcut to DataSplice.exe will be placed in the folder. 

• Right click on the Shortcut to DataSplice.exe file and choose Rename.  Change 
the filename to DataSplice Client. 

 
You can now run the DataSplice Remote Client application on the mobile device by 
selecting Start > Programs > DataSplice Client. 
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Configuring the Button Helper Utility 
If you have a Pocket PC device, one of the files that was transferred over to the mobile 
device is ButtonHelper.exe.  This application facilitates the binding of DataSplice actions 
to the hot keys on Pocket PC.  This application takes command line parameters (such as 
/newRecord) and posts the appropriate message to the running instance of DataSplice.  
This means that shortcuts can be made that perform the specified action, which in turn 
can be bound to device hot keys in the Control Panel.  To set up hot keys for DataSplice 
actions, perform the following steps: 
 

1. On the Pocket PC device, click Start > Settings. 
2. On the Personal tab, click the Buttons icon. 
3. In the Button column, select which button you would like to map an action to. 
4. In the Button assignment selection dropdown list, pick the action you want to 

associate with the selected button.  The DataSplice actions will begin with 
DataSplice – .  For example, to assign the DataSplice Search function to a button, 
you would select DataSplice – Search from the dropdown list. 

5. Repeat steps 3 and 4 for the other buttons you wish to set.  Click OK in the upper 
right corner when you are finished. 

 
The following list shows which actions are available for hot key mapping: 
 

• Clear Screen 
• Commit Changes 
• Delete Record 
• Get Offline Data 
• Login Screen 
• Narrow Search 
• Navigate Back 
• New Record 
• Next Page 
• Previous Page 
• Reset Record (Cancel Changes) 
• Search 
• Toggle Connection 
• View List 
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Initial Configuration Steps 
Now that the DataSplice Mobile Integration Suite has been successfully installed, there 
are some initial configuration items that should be completed: 
 

• Creating an ODBC Data Source 
• Launching the DataSplice Server 
• Connecting to the DataSplice Server 
• Enabling Functionality with a Valid License Key 
• Creating a Connection Profile 
• Testing Available Views 
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Creating an ODBC Data Source 
Open Database Connectivity (ODBC) is a widely accepted application programming 
interface (API) for database access.  Databases use proprietary data access schemes that 
require the use of different database languages.  ODBC eliminates the need to create code 
specific to each database, instead providing one standard set of calls.  The calls are 
translated to the appropriate language by the ODBC drivers.  Utilizing ODBC, databases 
are referred to by their Data Source Name (DSN). 
 
Note: If you have established your ODBC data source but it does not show up in 
DataSplice, please be sure to disconnect and reconnect with the DataSplice 
Administration Client.  Your data source should then be listed. 
 

Acquiring ODBC 
ODBC is required for DataSplice and is standard on many installations of Windows.  To 
verify that ODBC is installed, click Start > Settings > Control Panel > Administrative 
Tools.  If Data Sources (ODBC) is listed here, then it is already installed.  If you do not 
have ODBC, it is available for download from Microsoft at 
http://www.microsoft.com/data/download.htm. 
 

Data Sources 
Different types of data sources: 
 
User DSN 

An ODBC User Data Source Name stores information about how to connect to 
the indicated data provider.  A user data source is local to a computer and is 
accessible only by the current user. 

 
System DSN 

An ODBC System Data Source Name stores information about how to connect 
to the indicated data provider.  A system data source is local to a computer but is 
not user-dedicated.  Any user can access a system DSN.  In most cases, this is the 
preferred type of data source for use with DataSplice. 

 
File DSN 

An ODBC File Data Source Name allows you to connect to a data provider.  A 
file data source need not be user-dedicated or local to a computer. 

 
Note: DataSplice requires that each DataSplice Server have at least one DSN set for all 
databases utilized by DataSplice. 
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Creating a Data Source in Microsoft ODBC Data Source Administrator 
Before creating an ODBC data source, be sure the database server is configured.  For 
more information regarding configuration of the database, consult the documentation that 
was provided with the particular database. 
 
To create an ODBC data source: 
 

1. Launch the ODBC Data Source Administrator by selecting Start > Settings > 
Control Panel > Administrative Tools > Data Sources (ODBC). 

2. Select the appropriate DSN tab.  In most cases, you will want to use a system 
DSN: 

 

 
 

3. Click Add to begin creating the data source.  This will open the Create New 
Data Source dialog box: 
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4. Select the appropriate driver for the data source, and then click Finish.  A dialog 
box will appear to allow you to configure the data source.  Each data source driver 
has a different installation interface.  Consult the documentation provided with the 
data source for more information about how to complete the fields. 

 

 
 

5. After you have entered the appropriate information for your data source, click OK 
to finish.  You can make modifications to the data source later by highlighting the 
data source from the list on the System DSN tab and then clicking Configure. 

 

Drivers 
Databases use proprietary data access schemes that require the use of different database 
languages.  ODBC provides an interface that standardizes the syntax necessary to 
communicate with ODBC-compliant databases.  The ODBC drivers are responsible for 
translating the syntax into the database-specific language, which allows one set of code to 
access many different databases.  Each type of database utilized must have its own 
ODBC driver installed. 
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Installing ODBC Drivers 
In order to add or remove an ODBC driver, the setup utility that is specific to the 
particular driver and database must be run.  The Drivers tab in the ODBC Data Source 
Administrator only displays information about the drivers already installed. 
 
Note: Drivers may not be installed from this location. 
 

 
 

Connection Pooling 
When an application needs a particular driver, it first requests a connection handle with 
which to identify the driver and then requests that the Driver Manager load the driver.  
Connection pooling places these handles in a pool so that they may be reused without 
having to reestablish a connection, thus saving round-trips to the server and improving 
performance. 
 

Connection Pooling Tab 
The Connection Pooling tab sets the connection pooling timeout, retry wait time, and 
enables or disables performance monitoring. 
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• Connection Pooling Timeout – This specifies the time, in seconds, that unused 
connections will remain in the pool.  To set the connection pooling timeout, 
double click the appropriate driver.  The Set Connection Pooling Attributes 
dialog box appears: 

 

 
 

• PerfMon – Enable or disable performance monitoring by selecting the 
appropriate radio button for this option. 

• Retry Wait Time – This specifies the interval, in seconds, at which the ODBC 
Driver Manager retries to make a connection to the database server. 
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Launching the DataSplice Server 
To be able to access the DataSplice Server, the program must first be started.  The 
DataSplice Server can be launched in two distinct ways: 
 

• Launching the DataSplice Server as an Application 
• Launching the DataSplice Server as a Service 
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Launching the DataSplice Server as an Application 
The DataSplice Server can be launched as an application.  This allows it to be launched 
directly from the Start menu. 
 
One downside of launching the DataSplice Server as an application is that it has to be 
started manually.  Another drawback is that the application will stop running when the 
user who started it logs out. 
 
With these considerations in mind, the following steps can be used to launch the 
DataSplice Server as an application. 
 

Running the Application 
To launch the DataSplice Server through the Start menu: 
 

• Click Start > Programs > DataSplice > DataSplice Server. 
 

 
 
To launch the DataSplice Server by directly accessing the executable file: 
 

• Open Windows Explorer. 
• Browse to C:\Program Files\DataSplice, or other installation folder if 

DataSplice was not installed in the default location. 
• Double click the DSSplicer.exe file. 

 
A corresponding icon will appear in the system tray.  As it is starting up, the icon will 
show flashing colors to signify that the DataSplice Server is initializing .  No 
connections can be accepted to the DataSplice Server until it is done initializing. 
 
Once the DataSplice Server has finished initializing, the icon will stop flashing .  At 
this time, the DataSplice Server has successfully started and is now ready to receive 
connections. 
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Launching the DataSplice Server as a Service 
The DataSplice Server can be configured to run as a service.  While this requires an 
additional configuration step, it is often the preferred method for launching the 
DataSplice Server.  Compared to running as an application, launching it as a service has 
numerous advantages: 
 

• The DataSplice Server can start automatically when the server computer boots up. 
• It is launched independently from a particular user. 
• Additional behavior can be configured using the service properties dialog box. 

 

Configuring the Service 
To configure the DataSplice Server to run as a service: 
 

• Browse to C:\Program Files\DataSplice, or other installation path if different 
than the default location. 

• Double click the DSServiceInstall.bat file. 
• Click Start > Settings > Control Panel > Administrative Tools. 
• Double click Services. 
• Double click the DataSplice Service entry to open the Properties dialog box. 
• On the General tab, select Automatic from the Startup Type dropdown list to 

cause the service to start when the computer boots up: 
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• Select the Log On tab. 
• In the Log on as: section, select This account:. 
• Enter a valid local administrator account.  This allows the necessary permissions 

for an administrator to log in and stop the service if needed. 
• Enter and confirm the password in the appropriate fields: 

 

  29



  
  
                                                                               DataSplice Mobile Computing – Installation Guide 
 

 
 

• Click OK. 
 
When the DataSplice Server launches as a service, it will not generate an icon in the 
system tray.  To verify that it is running, you can open the Services panel and check its 
status.  You can also open Windows Task Manager and look for the DSSplicer.exe and 
DSService.exe processes. 
 
Note: If you have difficulty running the DataSplice Server as a service, please ensure that 
the latest MSXML library is properly installed on the computer. 
 

Removing the Service 
At some point, you may wish to remove the DataSplice Server service that you have 
previously configured.  You can use the following steps to do so. 
 
To remove the DataSplice Server service: 
 

• Browse to C:\Program Files\DataSplice, or other installation path if different 
than the default location. 

• Double click the DSServiceRemove.bat file. 
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Connecting to the DataSplice Server 
To configure items in the DataSplice Server, you first need to connect to it with the 
Administration Client. 
 
To connect to the DataSplice Server with the Administration Client: 
 

• Click Start > Programs > DataSplice > Administration Client. 
• When the Administration Client window opens, click File > Connect. 
• You will see the Connection Options dialog box: 

 

 
 

• Enter the default initial user name of Admin. 
• Enter the default initial password of changethis. 
• Enter the correct server address (if this is the same computer that the DataSplice 

Server is running on, this will be 127.0.0.1). 
• Click Connect. 
• Upon initial login, you will be presented with the Change Password dialog box: 

 

 
 

• Enter and confirm your new password and click Change. 
 
For more information, please see the Connection Options section of the DataSplice 
Administration Client User Manual. 
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Enabling Functionality with a Valid License Key 
To unlock the product’s full functionality, you will need to enter a valid license key in the 
Administration Client. 
 
To enter a license key: 
 

• Expand the System Information section in the left pane. 
• Select the Options item in the left pane. 
• In the right pane, select the Licenses tab. 
• In the Server License field, paste the appropriate license key that you received 

from a DataSplice representative: 
 

 
 

• Click the Update button . 
• You will be prompted to reconnect, at which time the product will have the 

appropriate functionality. 
 
For additional information, please see the Licenses Tab explanation in the DataSplice 
Administration Client User Manual. 
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Creating a Connection Profile 
To interact with data, you need to create a connection profile in the Administration 
Client.  The DataSplice Server uses connection profiles to define the details needed to 
connect to a data source for a particular view.  This will likely be the data source that you 
created in the previous Creating an ODBC Data Source section. 
 
To create a connection profile: 
 

• Expand the System Information section in the left pane. 
• Select the Options item in the left pane. 
• In the right pane, select the Connection Profiles tab. 
• Click the Add button. 
• In the Profile Name field, enter an appropriate name for the profile, such as 

maximo. 
• Double click the Data Source field to select the data source from the dropdown 

list. 
• In the User Name field, enter a user name with correct credentials to access this 

data source. 
• In the Password field, enter the password for the user you just entered: 

 

 
 

• Click the Update button . 
 
For additional information, please see the Connection Profiles Tab section of the 
DataSplice Administration Client User Manual. 
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